<!DOCTYPE html>
<html lang="en" xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:addthis="http://www.addthis.com/help/api-spec" >
<head>
	
	<meta charset="UTF-8" />
	<title>Rob Halford Looks Back on Judas Priest&#8217;s &#8216;Turbo&#8217; &laquo; 93.1 Jack FM</title>
	<meta name="description" content="&quot;It&#039;s normal to have a record or two where your fans push back a little bit,&quot; Halford says about the then-controversial album." />
	<link rel="pingback" href="http://931jackfm.cbslocal.com/xmlrpc.php" />
	<meta name="keywords" content="vibNews" />
								<meta name="news_keywords" content="judas priest" />
			
<!-- WP Header - Start -->
	<meta name="news_keywords" content="Judas Priest Turbo, Judas Priest turbo reissue, Judas Priest turbo hair metal, Judas Priest Turbo worst album, Rob Halford Judas Priest Turbo, Judas Priest Parental Guidance, Judas Priest PMRC" />
<meta name="keywords" content="judas priest turbo, judas priest turbo reissue, judas priest turbo hair metal, judas priest turbo worst album, rob halford judas priest turbo, judas priest parental guidance, judas priest pmrc" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=931jackfm.cbslocal.com&amp;id=37389071&amp;t=1486509879&amp;back=http%3A%2F%2F931jackfm.cbslocal.com%2F2017%2F02%2F07%2Frob-halford-judas-priest-turbo%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.evcdn.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//cbs931jackfm.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel="alternate" type="application/rss+xml" title="93.1 Jack FM &raquo; Feed" href="http://931jackfm.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="93.1 Jack FM &raquo; Comments Feed" href="http://931jackfm.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="93.1 Jack FM &raquo; Rob Halford Looks Back on Judas Priest&#8217;s &#8216;Turbo&#8217; Comments Feed" href="http://931jackfm.cbslocal.com/2017/02/07/rob-halford-judas-priest-turbo/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1473172720h&ver=4.6.1-RC1-38499"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJy1kt1OwzAMRl+IxFoBrVwgniVNTZfW+SF2KH170mmVNhCiXHB5Evvk06fAnJSNQTAI+KISlcEFhjnZ6BV7R7h8IW2Z7+BqTU7okeHdJbAdK4rWEIwM41vBvMArmjqRyQ0nuQHtXdgn21L52Beqt+ch5U0wA2aoitsT1SNPEtP/yJEqBfnew1V95KZqGlGSsZM6074w63PJZAmYGXIUI6YjVLPrB5S/Nh9nUtbkWBhpBb3BPhHLQrg/9o+9/PY/TLBLFz8urDdWB32vm9X24p8PD+1j+9S0zXH8BLPvAs4=' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-1-css'  href='https://fonts.googleapis.com/css?family=Questrial%7CArvo%3A400%2C700%7CMerriweather%3A400%2C900%7COswald%3A300%2C400%2C700%7CChanga+One%7CRighteous&#038;ver=1.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-2-css'  href='https://fonts.googleapis.com/css?family=Black+Ops+One%7CVollkorn%7COpen+Sans%3A300%2C400%2C700%2C800%7CMontserrat%3A300%2C400%2C700%7CLato%3A400%2C700%7CPT+Sans%3A400%2C700&#038;ver=1.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-squada-one-css'  href='https://fonts.googleapis.com/css?family=Squada+One%3A300%2C400%2C700&#038;ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-6-1' href='https://s2.wp.com/wp-content/themes/vip/cbs-local/css/audio-player.css?m=1356119360h' type='text/css' media='all' />
<link rel='stylesheet' id='music-css'  href='https://s0.wp.com/wp-content/themes/vip/cbs-local/plugins/modules/theme-manager/css/markets/music.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='http://wayne.cbslocal.com/tech/custom-css/music_sites/adult_hits.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-10-1' href='https://s0.wp.com/_static/??-eJyVj9EKwjAMRX/IGAXZ9iJ+S9eFrdq0pWnd75tNBspA8CWU23MPCc4JbAyFQsEyEZPg0yW0vYCP1nhMvo4uCHIcqtdfYZMLzG4YqaCV7+CowQH/Va4QsAlmpLw61eisp52OK2xlGzNpzsmUhWAanCGvorDf4qPGqdlay3My9iG/+DkpDX2fMomATnaV4X3W0rvx9Xxpz113apvu/gK2ynyE' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-12-1' href='https://s1.wp.com/_static/??-eJytj0sOwjAMRC9EMEilUheIs6SpCYYkrvJprk8aRAFVQizYjTX2Gw/kUSh2EV2EeEGLASYaQfVBGFbSwGiSJhfA8pBMcTMNGmMAFRa9LXoDBI4jFVZYxMN4S7BJPHkauSZEYvcxiLOR5L+deuwN6yJ1/eI1ro5+alSXhJVOavSVaKW/zR1tCqRAsWG/7vIXNk/os6eIM/5kj/um7Zr2sOua6x0BhZpN' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-external-css-css'  href='http://wayne.cbslocal.com/tech/custom-css/music_sites/adult_hits.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-14-1' href='https://s1.wp.com/wp-content/themes/h4/global.css?m=1420737423h' type='text/css' media='all' />
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJy1Uu1uwyAMfKEBytpO+TPtWShxUqdgGB/NsqefEzXS0lVr9mMSknX4fD6w1RAEkrGlgaR6Pu8F4ngNsk9P6jeCcNhFnUE6pIVsPGWgrPIJHJdcMChzTMJ6o+03gVaTGY/+Y2m1YFHJnXyWQZvzJkWdEqasKc/u2kImo6e01Q35QQSrR6RuU0mwpUNKyvmmWM7qZu7L4a/vB82MaLE75RXY/Je3VmaScJp0B3HqtLoQPL9z9uE/pMEy4gncaveTwhEtiJIgMpUy71Lr7/CCT5l9JCbdya63EumCMDyk9ZCnLRIREn7+UH0wHj9YYXT0bNxOQC7gOp4391rt68Ourl4Odf8Fr4M53g=='></script>
<script type='text/javascript' src='http://s1.evcdn.com/store/js/switchboard.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFjEsKwzAQQy+UdAgYk03IWVx72tiMP6Cxe/26qy6zEAj0nujTVl+LclHSizODRmzkn1ileifUpL9jAeUausyVx0RfXSj9+yNhobsjB0SoK4qf6sLFiIOneuZjM7uZscamL7ESNVk='></script>
<script type='text/javascript' src='http://apis.google.com/js/plusone.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokr90kz95PyiVL3czDy9rGIdfZyqyjNT0lNLCKsrSUwqhqqyz7U1NDE3NjQ3MjcyyAIAHAguDw=='></script>
<script type='text/javascript' src='http://ajax.cbslocal.com/jquery/modernizr/2.0.6/modernizr.min.js?ver=2.0.6'></script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJydjEsOwjAQQy9EOlSlIBaIs6TpNEw0+ZBJgN6eILFgCcgLy7L94J6UiaFgKFAu6FHgRgnMJIqj0QxOwF0r5vVtnYlcfaBlVX23bfIUOicb+Bk0aZWilLYUbfF/zsL4EKYZ87d/y3HS/NU6cbUUBHycK7e2CmaV0ZKUrAvF8OJ95kY9+1O/G4/DuD8MvXsCeRqDUQ=='></script>
<script type='text/javascript' src='http://ajax.cbslocal.com/jquery/jplayer/2.9.2/jquery.jplayer.min.js?ver=2.9.2'></script>
<script type='text/javascript' src='https://s2.wp.com/wp-content/themes/vip/cbs-local/js/audio-player.js?m=1447949191h'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cbs931jackfm.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='http://cbsloc.al/2llaBEW' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=http%3A%2F%2F931jackfm.cbslocal.com%2F2017%2F02%2F07%2Frob-halford-judas-priest-turbo%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=http%3A%2F%2F931jackfm.cbslocal.com%2F2017%2F02%2F07%2Frob-halford-judas-priest-turbo%2F&amp;for=wpcom-auto-discovery" /><link rel="shortcut icon" type="image/x-icon" href="http://0.gravatar.com/blavatar/0d1d951272601dc2ab62d51db00d9ae8?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://0.gravatar.com/blavatar/0d1d951272601dc2ab62d51db00d9ae8?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://0.gravatar.com/blavatar/0d1d951272601dc2ab62d51db00d9ae8?s=114" />
<link rel='openid.server' href='http://cbs931jackfm.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='http://cbs931jackfm.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="http://931jackfm.cbslocal.com/osd.xml" title="93.1 Jack FM" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style type="text/css">
			#wwWrapper { overflow: hidden; }
			#wwWidget { background: none; font-family: Arial, Helvetica, sans-serif; margin-bottom: 5px; overflow: hidden; padding: 5px; width: 170px; }
			#wwWidget a { text-decoration: none; }
			#wwWidget img { border: 0; float: left; margin: 3px 0 0 0; padding: 0; width: 28px; }
			#wwWidget span#wwTemp { color: #a6d4f7; font: normal 31px Helvetica, Arial, sans-serif; letter-spacing: 0; }
		</style>
			<link rel="canonical" href="http://radio.com/2017/02/07/rob-halford-judas-priest-turbo/" />
			<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="93.1 Jack FM" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Playing What We Want" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://931jackfm.cbslocal.com/feed/;icon-uri=http://0.gravatar.com/blavatar/0d1d951272601dc2ab62d51db00d9ae8?s=16" />
					<meta name="twitter:card" content="summary_large_image" />
			<meta name="twitter:image" content="https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=946">
		
					<meta name="twitter:title" content="Rob Halford Looks Back on Judas Priest&#039;s &#039;Turbo&#039;" />
					<meta name="twitter:description" content="&quot;It&#039;s normal to have a record or two where your fans push back a little bit,&quot; Halford says about the then-controversial album." />
					<meta name="twitter:site" content="931jackfm" />
		
		
					<meta property="og:title" content="Rob Halford Looks Back on Judas Priest&#039;s &#039;Turbo&#039;" />
					<meta property="og:image" content="https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=946" />
					<meta property="og:image:secure_url" content="https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=946" />
					<meta property="og:description" content="&quot;It&#039;s normal to have a record or two where your fans push back a little bit,&quot; Halford says about the then-controversial album." />
					<meta property="og:type" content="article" />
					<meta property="og:url" content="http://931jackfm.cbslocal.com/2017/02/07/rob-halford-judas-priest-turbo/" />
					<meta property="og:image:height" content="532" />
					<meta property="og:image:width" content="946" />
					<meta property="article:publisher" content="http://www.facebook.com/pages/931-JACK-FM/17709554381" />
					<meta property="article:author" content="http://www.facebook.com/pages/931-JACK-FM/17709554381" />
		
		<link rel="amphtml" href="http://931jackfm.cbslocal.com/2017/02/07/rob-halford-judas-priest-turbo/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>

							<script type="text/javascript" src="https://mtrx.go.sonobi.com/morpheus.cbslocal.3566.js"></script>
		
							<script type="text/javascript" src="http://c.amazon-adsystem.com/aax2/amzn_ads.js"></script>
			<script type="text/javascript" >
				try {
					amznads.getAds('3063');
				} catch(e) {}
			</script>
		
		
				<script type="text/javascript">
			var googletag = googletag || {};
			googletag.cmd = googletag.cmd || [];
			(function() {
				var gads = document.createElement("script");
				gads.async = true;
				gads.type = "text/javascript";
				var useSSL = "https:" == document.location.protocol;
				gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
				var node =document.getElementsByTagName("script")[0];
				node.parentNode.insertBefore(gads, node);
			})();
		</script>

		
					<script type="text/javascript">
				try {
					amznads.setTargetingForGPTAsync('amznslots');
				} catch(e) {}
			</script>
		
		
					<script type="text/javascript" src="//native.sharethrough.com/assets/tag.js" async></script>
		
				<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s0.wp.com/?custom-css=1&#038;csblog=2wSBx&#038;cscache=6&#038;csrev=65" />
		<!-- WP Header - End -->

	<script type="text/javascript">
		//<![CDATA[
			
			
					//]]>
	</script>

</head>

<body class="single single-post postid-145537 single-format-standard desktop-display-type  mp6 customizer-styles-applied market-template-music highlander-enabled highlander-light tag-judas-priest" style="background: url(https://cbs931jackfm.files.wordpress.com/2016/06/newjackbackground.png) no-repeat center top;">

			<!--[if lt IE 9]>
			<script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
		<![endif]-->
		<!--[if lte IE 8]>
			<div id="global-browser-not-supported">
				<p>Sorry, your browser is out-of-date and cannot support this site. Please upgrade to the latest version, or try another browser.</p>
				<p><a href="http://www.microsoft.com/windows/internet-explorer/default.aspx" target="_blank">Download Internet Explorer</a> | <a href="http://www.mozilla.com/firefox/" target="_blank">Download Firefox</a> | <a href="http://www.google.com/chrome" target="_blank">Download Chrome</a></p>
			</div>
		<![endif]-->
	
	<div id="wrapper" class="body-wrapper">




<header id="page-header" class="page-header-type-modular modular-header-station" style="">
	<div class="wrapper">
	<div id="page-header-inner" style="background-image:url(https://cbs931jackfm.files.wordpress.com/2016/04/931jackfm_1200x150.png);">

					

		<div id="header-rows" class="header-row">
							<div class="header-row-top header-row">
																		<div id="page-header-top-left" class="header-cell">
								<div id="component-links" class="header-component"><ul id="menu-header-radio-station-directory-menu" class="menu"><li id="menu-item-112382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-112382"><a href="http://radio.com/station-directory/local/">More Stations By Location</a>
<ul class="sub-menu">
	<li id="menu-item-112384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112384"><a href="http://radio.com/station-directory/local/arizona/">Arizona</a></li>
	<li id="menu-item-112385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112385"><a href="http://radio.com/station-directory/local/california/">California</a></li>
	<li id="menu-item-112386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112386"><a href="http://radio.com/station-directory/local/connecticut/">Connecticut</a></li>
	<li id="menu-item-112387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112387"><a href="http://radio.com/station-directory/local/florida/">Florida</a></li>
	<li id="menu-item-112388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112388"><a href="http://radio.com/station-directory/local/georgia/">Georgia</a></li>
	<li id="menu-item-112389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112389"><a href="http://radio.com/station-directory/local/illinois/">Illinois</a></li>
	<li id="menu-item-112390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112390"><a href="http://radio.com/station-directory/local/maryland/">Maryland</a></li>
	<li id="menu-item-112391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112391"><a href="http://radio.com/station-directory/local/massachusetts/">Massachusetts</a></li>
	<li id="menu-item-112392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112392"><a href="http://radio.com/station-directory/local/michigan/">Michigan</a></li>
	<li id="menu-item-112393" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112393"><a href="http://radio.com/station-directory/local/minnesota/">Minnesota</a></li>
	<li id="menu-item-112394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112394"><a href="http://radio.com/station-directory/local/missouri/">Missouri</a></li>
	<li id="menu-item-112395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112395"><a href="http://radio.com/station-directory/local/nevada/">Nevada</a></li>
	<li id="menu-item-112396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112396"><a href="http://radio.com/station-directory/local/new%20york/">New York</a></li>
	<li id="menu-item-112397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112397"><a href="http://radio.com/station-directory/local/north%20carolina/">North Carolina</a></li>
	<li id="menu-item-112398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112398"><a href="http://radio.com/station-directory/local/ohio/">Ohio</a></li>
	<li id="menu-item-112399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112399"><a href="http://radio.com/station-directory/local/pennsylvania/">Pennsylvania</a></li>
	<li id="menu-item-112400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112400"><a href="http://radio.com/station-directory/local/texas/">Texas</a></li>
	<li id="menu-item-112401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112401"><a href="http://radio.com/station-directory/local/washington/">Washington</a></li>
	<li id="menu-item-112402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112402"><a href="http://radio.com/station-directory/local/washington%20d.c./">Washington, D.C.</a></li>
</ul>
</li>
<li id="menu-item-112383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112383"><a href="http://931jackfm.cbslocal.com/newsletter/signup/">SIGN UP FOR NEWSLETTERS</a></li>
</ul></div>
							</div>
																								<div id="page-header-top-right" class="header-cell">
								<div id="component-account" class="header-component"><div id="sso-header-wrapper"></div></div>
<div id="component-search" class="header-component"><form action="http://931jackfm.cbslocal.com/search/" class="search"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search" /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="Search" /></form></div>
							</div>
															</div>
			
			<div class="header-row-inner header-row">
													<div id="page-header-tall-left" class="header-cell">
						<a href="http://931jackfm.cbslocal.com" id="component-logo" class="header-component"><img src="https://cbs931jackfm.files.wordpress.com/2016/05/jackfmred.png" alt="93.1 Jack FM" /></a>
					</div>
				
													<div id="page-header-tall-right">
						<div id="component-sponsored-ad" class="header-component">
<div class="sponsored-by ad-size-120x60">

			<strong class="disclosure">Sponsored By</strong>
	
	<div class="cbs-ad-unit-wrapper"><div id="ad_10" class="cbs-ad-unit ad_gpt sponsor-unit" data-id="10" data-max-width="120" data-max-height="60"></div></div>
</div></div>
					</div>
				
				<div class="header-row-middle-and-bottom header-row">
											<div class="header-row-middle header-row">
																																							<div id="page-header-middle-right" class="header-cell">
										<a href="http://losangeles.cbslocal.com/weather" id="component-weather" class="header-component weather-widget" data-key="245c93fff38d0d82" data-location="90006"></a>
									</div>
																					</div>
					
											<div class="header-row-bottom header-row">
																																							<div id="page-header-bottom-right" class="header-cell">
										<div id="component-social" class="header-component follow-us social-follow-items size-24x24 type-grey"><a href="http://www.facebook.com/pages/931-JACK-FM/17709554381" class="facebook" target="_blank">Facebook</a><a href="http://www.twitter.com/#!/931jackfm" class="twitter" target="_blank">Twitter</a><a href="http://tunein.com/radio/-s31956" class="tunein" target="_blank">TuneIn</a></div>
									</div>
																					</div>
					
				</div>

			</div>

		</div>

	</div>
	</div>
</header>

<header id="main-header" class="old-main-header">
<nav class="main-nav">
	<ul id="menu-header-menu" class="menu"><li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home"><a href="http://931jackfm.cbslocal.com"><strong>Home</strong></a></li>
<li id="menu-item-20" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/category/music"><strong>Music</strong></a></li>
<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/category/jacked-up-news/"><strong>Jacked Up News</strong></a></li>
<li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://events.931jackfm.cbslocal.com"><strong>Jacktivities</strong></a></li>
<li id="menu-item-24" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/category/contests"><strong>Contests</strong></a></li>
<li id="menu-item-26" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/playlist"><strong>Playlist</strong></a></li>
<li id="menu-item-95844" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://931jackfm.cbslocal.com/richard-blades-flashback-lunch/"><strong>Flashback Lunch</strong></a></li>
</ul></nav>
<nav class="sub-nav">
	</nav>
</header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div class="positioning-wrapper">
				<table cellpadding="0" cellspacing="0"><tr><td align="center">
					<div class="cbs-ad-unit-wrapper"><div id="ad_1" class="cbs-ad-unit ad_gpt full-ad page-pencil-ad" data-id="1" data-max-width="970" data-max-height="250"></div></div>				</td></tr></table>
			</div>
		</section>
		
<div id="page-content" class="main-white page-block-container">
<section class="page-columns">

	<header class="page-section-title three-column">
		<div class="column-header">
			<h1 class="posttitle">Rob Halford Looks Back on Judas Priest&#8217;s &#8216;Turbo&#8217;</h1>
			<span class="post-subtitle">"It's normal to have a record or two where your fans push back a little bit," Halford says about the then-controversial album.</span>			<em class="entry-date">February 7, 2017 1:12 PM</em>
			
			
		</div>

								<div class="column-header-metadata">
				<strong>Filed Under:</strong> <span><a href="http://931jackfm.cbslocal.com/tag/judas-priest/">Judas Priest</a></span>
			</div>
			</header>

	<section class="page-column two-column columns-left">
		<section class="column-item media-type-image" id="featured-media"><div class="ndn_embed" id="ndn-video-player-1" data-config-distributor-id="92532" style="width:100%;" data-config-height="9/16w"></div><script type="text/javascript">cbs_lib.load_script("https://launch.newsinc.com/js/embed.js");</script>
			<script type="text/javascript">
				var _ndnq = _ndnq || [];
				_ndnq.push(["hook", "ndn-video-player-1/videoLoad", function(event) {
					jQuery(".mobile .article-thumbnail").hide();
				}]);
			</script><div class="thumbnail-wrapper"><img width="640" height="360" src="https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=640&amp;h=360&amp;crop=1" class="attachment-medium-16-9 size-medium-16-9 wp-post-image" alt="Judas Priest from the \&#039;Turbo\&#039; era (Photo Credit: Ross Halfin)" srcset="https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=640&amp;h=360&amp;crop=1 640w, https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=150&amp;h=84&amp;crop=1 150w, https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=300&amp;h=169&amp;crop=1 300w, https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg?w=768&amp;h=432&amp;crop=1 768w, https://cbs931jackfm.files.wordpress.com/2017/02/judas-priest.jpg 946w" sizes="(max-width: 640px) 100vw, 640px" /><div class="title-wrapper"><em class="caption">Judas Priest from the \'Turbo\' era (Photo Credit: Ross Halfin)</em></div></div></section>

		<section class="column-item" id="main-story">
			<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
								<span><a class="addthis_button_facebook" ></a><a class="addthis_button_twitter" ></a><a class="addthis_button_compact" ></a></span>
			</div>
		
		
					<a href="#comments" class="comments-link onclick-scrollto on-click-open-block" data-onclick-scrollto=".comments-location-beacon" data-onclick-open="#story-comments"></a>
			</div>
</div>
			<article class="article-bucket content">
				<div class="story">
					<p><em><strong>By Brian Ives</strong></em></p>
<p><em>Judas Priest was at the forefront of heavy metal — sonically and visually — in the &#8217;70s and &#8217;80s, and their fans loved them for it. Until 1986&#8217;s </em><a href="https://geo.itunes.apple.com/us/album/turbo-30-remastered-30th-anniversary/id1183873052?mt=1&amp;app=music&amp;at=1l3vnbv">Turbo</a>, <em>their most controversial album among metalheads</em><em>. First of all, there were synthesizers, the very presence of which delegitimized the album in the eyes of many metal fans. Then, there was the band&#8217;s new look: teased hair, and long leather coats, instead of biker jackets; they seemed to go from being dangerously tough dudes to hopeful heartthrobs.  The phase didn&#8217;t last long: 1988&#8217;s </em>Ram It Down <em>was a return to form, and 1990&#8217;s </em><a href="https://geo.itunes.apple.com/us/album/painkiller/id207178142?mt=1&amp;app=music&amp;at=1l3vnbv">Painkiller</a> <em>was as heavy as anything they ever did. </em></p>
<p><em>But, thirty years later, Judas Priest has released a </em>Turbo <em>reissue, with a remastered version of the album, and two bonus discs documenting a live concert from the band&#8217;s 1986 tour. Frontman Rob Halford spoke to </em>Radio.com <em>about the album and how history has treated it. </em></p>
<p>~</p>
<p><strong>Obviously, <em>Turbo</em> was very different from anything Judas Priest had done before.</strong></p>
<p>One of the major things was that for the first time in many, many years, we were able to take our time in making a record. Prior to that, we&#8217;d just been bashing them out at a ferocious speed. When I look back at how we were able to accomplish what we did, and the quality of the work, it&#8217;s quite remarkable.</p>
<p><strong>You clearly were going for something different this time around. The sound was really different, and so was the look.</strong></p>
<p>We had all these new ideas, like using guitar synthesizers and so forth, and we were just very interested and intrigued by what we could do with these new inventions. To have these sounds, it was an exciting time. We were coming off of back-to-back big records, [1982&#8217;s] <em>Screaming for Vengence</em> and [1984&#8217;s] <em>Defenders of the Faith</em>, and I think we were just looking, as much as ever, for a new experience. And that happened in the &#8217;80s for a lot of bands, not just Judas Priest. We got caught up in all that. It&#8217;s a unique album in our catalog, nothing comes remotely close to it.</p>
<p style="text-align:center;"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='555' height='312' src='http://www.youtube.com/embed/JhY9GOhFwN4?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><strong>Fans were up in arms about it at the time, but in 2014 and no one seemed mad about the <em>Turbo</em> songs anymore. </strong></p>
<p>Once Glenn [Tipton, guitarist] plays that opening &#8220;Turbo Lover&#8221; sound, everyone goes nuts. It just goes to show you that time can give you a different perspective on something that was controversial, and now is enjoyed with affection.</p>
<p>If you are fortunate enough to be successful through the decades, as Priest has, it&#8217;s normal to have a record or two where your fans push back a little bit. There&#8217;s still a portion of Priest fans who only want [1990&#8217;s] <em>Painkiller</em>, <em>Painkiller</em>, <em>Painkiller</em>. Or [1980&#8217;s] <em>British Steel</em>, <em>British Steel</em>, <em>British Steel</em>. That&#8217;s the way life works. But for Priest, <em>Turbo</em> was one of our most successful albums, and probably one of our more successful tours.</p>
<p><strong>Related: <a href="http://radio.com/2017/02/03/rob-halford-ranks-black-sabbath-albums/">Rob Halford Ranks Black Sabbath&#8217;s Albums</a> </strong></p>
<p><strong>What was behind the decision to change your look?</strong></p>
<p>Remember when Metallica cut their hair?</p>
<p><strong>Who could forget!</strong></p>
<p>Well, there you go. You do what you do at the time you do it: it could be because you just to shake things up a bit in your own band, or because you&#8217;re surrounded by all these other things that are going on around you, and you want to step into that arena and have some fun&#8230; yeah, we went towards a different look. Only for that one album! I think the visual image married perfectly to the sound of the album. The way we looked for <em>Painkiller</em> was perfect for that album; you try and wrap it all up in one presentation that is inclusive of everything that&#8217;s going on around you.</p>
<p><strong>As much as metal is &#8220;outsider&#8221; music, there&#8217;s still a bit of conservatism there. &#8220;Don&#8217;t ever change!&#8221;</strong></p>
<p>That&#8217;s very true; I don&#8217;t know if that&#8217;s exclusive to metal. But there&#8217;s definitely a sense of: &#8220;We should all look this way, we should all act this way,&#8221; which I think is very important. So when you mess with that, the fans will let you know [laughs]. Fortunately, it happened for us at a time when we could do it. If we released an album like <em>Turbo</em> now, it would be a very dangerous thing for us to do.</p>
<p style="text-align:center;"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='555' height='312' src='http://www.youtube.com/embed/OWWXfkkRGyM?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><strong>I was listening to &#8220;Parental Guidance&#8221; and thinking that that song &#8211; which railed against Tipper Gore&#8217;s PMRC &#8212; is almost quaint now.</strong></p>
<p>It <em>is</em> almost quaint now, but it was relevant at the time. But I think it was important that we pushed back a little bit with what we were being subjected to. &#8220;We don&#8217;t need parental guidance,&#8221; that was about as angry as we got, in terms of tone. It was kind of a bitch-slap, but even then, it was kind of lukewarm, in terms of a statement. It&#8217;s not an album filled with f&#8212;ing blood and guts and thunder. It&#8217;s a feel-good album, it&#8217;s almost a party album.</p>

<!-- AddThis Button Begin -->
<script type="text/javascript">var addthis_product = 'wpp-261';
var addthis_config = {"data_track_clickback":false};if (typeof(addthis_share) == "undefined"){ addthis_share = {"templates":{"twitter":"{{title}} {{url}} via @931jackfm"},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{"login":"cbslocal","apiKey":"R_bfe2742f79bb4091b0fcfbdf5c6a81ca"}}};}</script><script type="text/javascript" src="//s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4ddd05dc24272928"></script>				</div>
			</article>

					</section>

		<div class="column-item" id="story-anchor-comments"><a href="#comments" class="onclick-scrollto on-click-open-block" data-onclick-scrollto=".comments-location-beacon" data-onclick-open="#story-comments">Comments</a></div><div class="cbs-ad-unit-wrapper"><div id="ad_31" class="cbs-ad-unit ad_gpt partner-container partner-sharethrough" data-id="31" data-max-width="1" data-max-height="5"></div></div><div class="partner-container partner-taboola"><div id="taboola-block-1"></div></div>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #dfe3e6;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							<p class="no-comments">Comments are closed.</p>
			
		</div>

	</section>
</div>
	</section>

	
<aside class="sidebar right-bar">
	<div id="listen-live-button" class="listen-live-action"><div class="cbs-ad-unit-wrapper"><div id="ad_32" class="cbs-ad-unit ad_gpt listen-live-ad-block" data-id="32" data-max-width="88" data-max-height="31"></div></div><a class="listen-live-logo" href="http://player.radio.com/listen/station/931-jack-fm-la" target="_blank" title="Listen to Live Radio" style=""></a><a class="wrapper" href="http://player.radio.com/listen/station/931-jack-fm-la" target="_blank"><p class="listen-live-text listen">Listen Live</p></a></div><div class="cbs-ad-unit-wrapper"><div id="ad_2" class="cbs-ad-unit ad_gpt big-right-ad" data-id="2" data-max-width="300" data-max-height="1050"></div></div><div id="sidebar-smart-widget-1" class="smart-widget-container"><div id="component-article-social" class="sidebar-component follow-us"><span class="disclosure">Follow Us On</span><div class="social-container"><span class="social-icons icon-count-3"><a href="http://www.facebook.com/pages/931-JACK-FM/17709554381" class="facebook" target="_blank">Facebook</a><a href="http://www.twitter.com/#!/931jackfm" class="twitter" target="_blank">Twitter</a><a href="http://tunein.com/radio/-s31956" class="tunein" target="_blank">TuneIn</a></span></div><span class="newsletter-signup"><a target="_blank" href="http://931jackfm.cbslocal.com/newsletter/signup/">Sign Up for Newsletters</a></span></div></div><div class="cbs-ad-unit-wrapper"><div id="ad_33" class="cbs-ad-unit ad_gpt big-right-ad sidebar-adhesive-ad" data-id="33" data-max-width="300" data-max-height="250"></div></div><div id="ev-rightrail-widget-id" class="partner-container partner-eventful"> <div class="ev-container ev-article-rec ev-triple"></div></div>
</aside>

</section>



</div>

		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div class="positioning-wrapper">
				<table cellpadding="0" cellspacing="0"><tr><td align="center">
					<div class="cbs-ad-unit-wrapper"><div id="ad_4" class="cbs-ad-unit ad_gpt full-ad page-pencil-ad" data-id="4" data-max-width="728" data-max-height="90"></div></div>				</td></tr></table>
			</div>
		</section>
		
<section class="items-grid page-block-container layout-3_column aspect-ratio-16-9" id="drip-pan" >
		<header class="column-header">
				<h4 class="title">More From 93.1 Jack FM</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://931jackfm.cbslocal.com/tag/los-angeles/" title="Best Of Los Angeles" class="cbs-thumbnail-link item-1440696569" ><div class="thumbnail-wrapper"><img src="https://s0.wp.com/wp-content/themes/vip/cbs-local/images/global/blank_1x1.gif" data-src="https://cbs931jackfm.files.wordpress.com/2015/08/best-of-la.jpg?w=310&#038;h=174&#038;crop=1"></div><div class="title-wrapper"><strong class="title">Best Of Los Angeles</strong></div></a><a href="http://events.931jackfm.cbslocal.com/" title="JACKtivites" class="cbs-thumbnail-link item-1342657657" ><div class="thumbnail-wrapper"><img src="https://s0.wp.com/wp-content/themes/vip/cbs-local/images/global/blank_1x1.gif" data-src="https://cbs931jackfm.files.wordpress.com/2012/07/jacktivities1.jpg?w=310&#038;h=174&#038;crop=1"></div><div class="title-wrapper"><strong class="title">JACKtivites</strong></div></a><a href="http://931jackfm.cbslocal.com/2013/07/08/richard-blades-flashback-lunch/" title="Flashback Lunch" class="cbs-thumbnail-link item-1341852004" ><div class="thumbnail-wrapper"><img src="https://s0.wp.com/wp-content/themes/vip/cbs-local/images/global/blank_1x1.gif" data-src="https://cbs931jackfm.files.wordpress.com/2013/07/flashback-lunch-600.jpg?w=310&#038;h=174&#038;crop=1"></div><div class="title-wrapper"><strong class="title">Flashback Lunch</strong></div></a>		</div>
	</section>

<footer id="page-footer" class="page-footer-type-menus-horizontal">
			<section class="top">
			<a href="http://931jackfm.cbslocal.com" class="logo"><img src="http://cbs931jackfm.files.wordpress.com/2014/01/jack-logo-170.png" alt="93.1 Jack FM" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/pages/931-JACK-FM/17709554381" class="facebook" target="_blank">Facebook</a><a href="http://www.twitter.com/#!/931jackfm" class="twitter" target="_blank">Twitter</a><a href="http://tunein.com/radio/-s31956" class="tunein" target="_blank">TuneIn</a>					</div>
				</div>
					</section>
	
			<section class="middle">
							<div class="navigation-menus menu-count-5">
					<div class="menu-block"><div class="title">93.1 Jack FM</div><div class="menu-footer-93-1-jack-fm-container"><ul id="menu-footer-93-1-jack-fm" class="footer-navigation nav-footer-list-1"><li id="menu-item-127988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-127988"><a href="http://931jackfm.cbslocal.com/">Home</a></li>
<li id="menu-item-127989" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127989"><a href="http://events.931jackfm.cbslocal.com/">JACK-Tivities</a></li>
<li id="menu-item-127990" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127990"><a href="http://931jackfm.cbslocal.com/photo-galleries/">Photos</a></li>
</ul></div></div><div class="menu-block"><div class="title">Music</div><div class="menu-footer-music-container"><ul id="menu-footer-music" class="footer-navigation nav-footer-list-2"><li id="menu-item-127991" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127991"><a href="http://931jackfm.cbslocal.com/category/music/">Jacked News</a></li>
<li id="menu-item-127992" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127992"><a href="http://931jackfm.cbslocal.com/playlist/">Play History</a></li>
</ul></div></div><div class="menu-block"><div class="title">Contests</div><div class="menu-footer-contests-container"><ul id="menu-footer-contests" class="footer-navigation nav-footer-list-3"><li id="menu-item-127993" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127993"><a href="http://931jackfm.cbslocal.com/category/contests/">Win Stuff</a></li>
<li id="menu-item-127994" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127994"><a href="http://931jackfm.cbslocal.com/tag/contest-rules/">Contest Rules</a></li>
</ul></div></div><div class="menu-block"><div class="title">Contact Us</div><div class="menu-footer-contact-us-container"><ul id="menu-footer-contact-us" class="footer-navigation nav-footer-list-4"><li id="menu-item-127995" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127995"><a href="https://twitter.com/931JACKFM">Twitter</a></li>
<li id="menu-item-127996" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127996"><a href="http://www.facebook.com/pages/931-JACK-FM/17709554381">Facebook</a></li>
<li id="menu-item-127997" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127997"><a href="http://931jackfm.cbslocal.com/advertise-with-us">Advertise With Us</a></li>
<li id="menu-item-127998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-127998"><a href="http://www.cbsradio.com/careers">Careers</a></li>
</ul></div></div><div class="menu-block"><div class="title">Corporate</div><div class="menu-footer-corporate-container"><ul id="menu-footer-corporate" class="footer-navigation nav-footer-list-5"><li id="menu-item-137976" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-137976"><a href="http://policies.cbslocal.com/fcc/losangeles.radio.html">CBS Radio Public File</a></li>
</ul></div></div>				</div>
					</section>
	
			<section class="bottom">
			<a href="http://931jackfm.cbslocal.com" class="logo"><img src="https://s0.wp.com/wp-content/themes/vip/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="93.1 Jack FM" /></a>
			<div class="copyright-wrapper">
								<span class="copyright">&copy;2017 CBS Radio Inc. All Rights Reserved.</span>

									<span class="powered-by-wordpress">
						Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>					</span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="http://policies.cbslocal.com/privacy-june-2015/current.html#video-services" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-27" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27"><a href="http://policies.cbslocal.com/privacy/">Privacy Policy</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-125987" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-125987"><a href="http://policies.cbslocal.com/privacy/current.html#cali-visitors">Your California Privacy Rights</a></li>
<li id="menu-item-125988" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-125988"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-87859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-87859"><a href="http://policies.cbslocal.com/privacy/current.html#onlinead">Ad Choices</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29"><a href="https://cbs931jackfm.files.wordpress.com/2016/08/cbs_radio-los_angeles_eeo_public_file_report_2015-2016.pdf">EEO Reports</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="http://931jackfm.cbslocal.com/category/contests/">Contest Rules</a></li>
</ul>			</div>

					</section>
	</footer>

<!--PARTNER SCRIPTS START-->
<div class="cbs-ad-unit-wrapper"><div id="ad_34" class="cbs-ad-unit ad_gpt" data-id="34" data-max-width="1" data-max-height="8"></div></div><div class="cbs-ad-unit-wrapper"><div id="ad_35" class="cbs-ad-unit ad_gpt" data-id="35" data-max-width="1" data-max-height="6"></div></div><div class="cbs-ad-unit-wrapper"><div id="ad_36" class="cbs-ad-unit ad_gpt" data-id="36" data-max-width="1" data-max-height="7"></div></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- wpcom_wp_footer -->

<!-- AddThis Button Begin -->
<script type="text/javascript">var addthis_product = 'wpp-261';
var addthis_config = {"data_track_clickback":false};if (typeof(addthis_share) == "undefined"){ addthis_share = {"templates":{"twitter":"{{title}} {{url}} via @931jackfm"},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{"login":"cbslocal","apiKey":"R_bfe2742f79bb4091b0fcfbdf5c6a81ca"}}};}</script><script type="text/javascript" src="//s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4ddd05dc24272928"></script>		<script type="text/javascript">
			!function(d,s,id){
				var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';
				if(!d.getElementById(id)){
					js=d.createElement(s);
					js.id=id;js.src=p+"://platform.twitter.com/widgets.js";
					fjs.parentNode.insertBefore(js,fjs);
				}
			}(document,"script","twitter-wjs");
		</script>
		<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201706y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/themes/vip/cbs-local/plugins/modules/partners/css/partners.css?m=1483458356h' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJx9jkEOwiAQRS8kjq1NdGM8yxQmFoQpMkD19lIXxrjobvL/fy8DS1R65kycwQkYqlZTfO6d7OCnCkVFX26WBby9k8CjUKEJ2XhK/+M8UWiTaiPoUZSfNfpVLmVkrBvqXq2M+6AKGf0rWy0bAJpgWY2YIKBkSu1Sc6WUrGkPfLNmuIZLN5wOw3Hozr17A3jgWrE='></script>
<script type='text/javascript' src='http://cbstv.us.intellitxt.com/intellitxt/front.asp?ipid=24443&#038;ver=1.0.0'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'37389071','blog_tz':'-8','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'37389071','v':'wpcom','tz':'-8','user_id':'0','post':'145537','subd':'cbs931jackfm'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=37389071&v=wpcomvt&tz=-8&user_id=0&post=145537&subd=cbs931jackfm&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTdocExCODFfQnlZTGxWLFVFPVlVSzZxZ0xDODBzU3dseGF2Z3Aldm83QXktLzczYlV6U3BQRlVpSTFkTGYwJkZ+Q2NTbGdoYX5kZnJQfHpfemQ5WHl4eldzTWpJdHxaXVpNTHVpMFtiX1NtOENTW1JFaUltdHBzd2ZML25ZLFsyS2luQz94cTQ0eGE4bixtbHZIaUs5ZDJJZWtkLWJXVll3K1BrYiU/cDZrZ2hXMGJLSlpobXFiWiZ2dlY1RzlWJXxFdWk3X1FdeiV3aVZoaXMuSEFqRWZl'}]);
_stq.push([ 'clickTrackerInit', '37389071', '145537' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>

<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({article:"auto"});!function (e, f, u, i) {if (!document.getElementById(i)){e.async = 1;e.src = u;e.id = i;f.parentNode.insertBefore(e, f);}}(document.createElement("script"),document.getElementsByTagName("script")[0],"//cdn.taboola.com/libtrc/cbslocal-network/loader.js","tb_loader_script");</script>
<script type="text/javascript">
	var cbs_market_root = 'http://931jackfm.cbslocal.com';
	var cbs_template_root = 'https://s0.wp.com/wp-content/themes/vip/cbs-local';
	var cbs_market_gmt_offset = -28800;

	var site_url = 'http://931jackfm.cbslocal.com';

	var cbs_sso_url_base = "https://my.cbslocal.com";
_taboola.push({mode:"thumbnails-a",container: "taboola-block-1",placement: "Below Article Thumbnails",target_type: "mix"});_taboola.push({flush: true});
	jQuery(function($) {
		cbs_lib.weather_widget("#page-header #component-weather");

cbs_adhesive.add( '#main-story .social-buttons', 'main-story', '#main-story', 'activator-top' );
cbs_adhesive.add( '.sidebar-adhesive-ad', 'sidebar', '.page-columns', 'activator-top' );
$('.ev-container.ev-article-rec').on('evComplete', function(event, param) {cbs_adhesive.add( '#ev-rightrail-widget-id .ev-container .cbs-articles:nth-child(0n+3)', 'sidebar', '.page-columns', 'activator-top' );
cbs_adhesive.add( '#ev-rightrail-widget-id .ev-container .cbs-powered', 'sidebar', '.page-columns', 'activator-top' );
});
	});

	jQuery(function($) { jQuery(window).load(function () { setTimeout(function () {
			}, 500); }); });

	jQuery(function($) { jQuery(window).load(function () { setTimeout(function () {
		cbs_lib.load_script("//native.sharethrough.com/assets/sfp.js");

		var user_info = decodeURI(cbs_lib.get_cookie('sso-userdata'));
		var user_data_string = '';

		//Make sure the cookie exists and make sure it is not set to empty after loggin out.
		if (typeof user_info !== 'undefined' && typeof user_info !== null && user_info) {
			var user_data_obj = JSON.parse(user_info);

			if (user_data_obj) {
				if (user_data_obj.hasOwnProperty('ZipCode')) {
					user_data_string += '&zip=' + encodeURIComponent(user_data_obj.ZipCode);
				}
				if (user_data_obj.hasOwnProperty('Gender')) {
					user_data_string += '&gd=' + encodeURIComponent(user_data_obj.Gender);
				}
				if (user_data_obj.hasOwnProperty('Age')) {
					user_data_string += '&ag=' + encodeURIComponent(user_data_obj.Age);
				}
			}
		}

		cbs_lib.load_script("https:\/\/loadus.exelator.com\/load\/?j=d&p=279&g=035&global=cbslocal&interface=site&station=http%3A%2F%2F931jackfm.cbslocal.com&ctg1=classic&category=classic%2Cheadlines%2Cinterview%2Cinterviews%2Clatest-headlines%2Cmusic&ctg2=headlines&ctg3=interview&ctg4=interviews&ctg5=latest-headlines&ctg6=music&location=losangeles&type=local&group=music&genre=adulthits&tit=rob-halford-judas-priest-turbo" + user_data_string);

		}, 5000); }); });

</script>

	
			
		<script type="text/javascript">
			var use_ga = true;
			var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
			document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
		</script>

		<script type="text/javascript">
			try {
				var is_logged_in = false;

				var formatTracker = _gat._getTracker("UA-20574553-6"); formatTracker._setCustomVar(1, "User Type", is_logged_in ? "User" : "Guest", 2); formatTracker._trackPageview();
				var marketTracker = _gat._getTracker("UA-19997300-13"); marketTracker._setCustomVar(1, "User Type", is_logged_in ? "User" : "Guest", 2); marketTracker._trackPageview();
				var rollupTracker = _gat._getTracker("UA-20574761-1"); rollupTracker._setCustomVar(1, "User Type", is_logged_in ? "User" : "Guest", 2); rollupTracker._trackPageview();
				var pageTracker = _gat._getTracker("UA-17913619-15"); pageTracker._setCustomVar(1, "User Type", is_logged_in ? "User" : "Guest", 2);
				pageTracker._trackPageview("/category/classic" + window.location.pathname + "?cat=classic;cat=headlines;cat=interview;cat=interviews;cat=latest-headlines;cat=music;");
			}
			catch(err) {}
		</script>

			
		<script type="text/javascript">
			var _comscore = _comscore || [];
			_comscore.push({
				c1: "2",
				c2: "3000023"
									,options: { url_append: "comscorekw=classic" }
							});
			(function() {
				var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=3000023&cv=2.0&cj=1" /></noscript>

	
		<script type='text/javascript'>_satellite.pageBottom();</script>

	<!-- Moat and Cloudfront tracking pixels -->
	<img src="//dbg52463.moatads.com?a=033f43a2ddba4ba592b52109d2ccf5ed" style="display:none;"> 
	<img src="//d5i9o0tpq9sa1.cloudfront.net?a=033f43a2ddba4ba592b52109d2ccf5ed" style="display:none;">
	
		<script type="text/javascript">
		(function(d, s, id) { 
			var js, evjs = d.getElementsByTagName(s)[0]; 
			if (d.getElementById(id)) return; 
			js = d.createElement(s); js.id = id; 
			js.src = "//s1.evcdn.com/store/plugins/tracker-ev-sdk.js"; 
			evjs.parentNode.insertBefore(js, evjs); 
		}(document, 'script', 'tracker-ev-sdk'));
	</script>

			<div id="listen-live-wrapper">
			<div class="listen-live">
				<div class="header">
					<div class="listen-live-logo"></div>
					<h3>Listen Live</h3>
														</div>
				<div class="listen-live-content">
					<div class="lead-wrapper">
						
											
					</div>

					<a href="https://www.audioadcenter.com/" class="advertise-on-our-streams" target="_blank">Advertise On Our Streams</a>
				</div>
			</div>
		</div>
		
		
	<div id="ad_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin"></div>
<script type="text/javascript">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</script>

</body>
</html>